HTC EVO 4G Forum

Support HELP: I can't push files using ADB!

First, I'm not rooted. I don't need root to push files using ADB though. I'm trying to push a file to "system/app" using ADB but I keep getting "permission denied". I've read countless threads and still cant get it.

I can get everything started,

F:\Android SDK\tools\
F: adb devices

Than it list my devices. Than I type in

F:adb shell and I get a "$" sign.

Anything I type after that I get permission denied.

I tried adb push [insert file here] /system/app I get

"ADB: Permission Denied."

I tried adb remount, I get 'ADB: Permission Denied"

Here is my log:
Any help


#1 Raadius, Aug 8, 2010
Are you supposed to be in fastboot USB when doing this?
#2 JG-1, Aug 8, 2010
You have to boot into recovery first to push files into system I believe since you are not rooted.
#3 im0rtalz, Aug 8, 2010
How do I do that?
#4 Raadius, Aug 8, 2010
In the adb shell

adb reboot recovery

Question though, I'm guessing you dont want to root your phone?
#5 im0rtalz, Aug 8, 2010
Whoops sorry that wouldn't help. You would still need root for su permissions for /system.
#6 im0rtalz, Aug 8, 2010
you are not using adb correctly.

1) if you are using adb shell, you are now in shell mode, and you should be using standard linux commands. The "permission denied" error you are getting is misleading. If you type kjdzgkjfdlkgdhgslkhfdg and press enter, it will say permission denied. You should read the error as "unknown command."

2) if you want to use adb to push files to your phone, you need to do that from your windows prompt, not inside adb shell. For example:

3) I believe that you need to specify the target file name. it's not enough to specify the directory. See my push example above.

4) /system/app is a root-only area. You can't mount that writable without root. So even if you got all the syntax right, it wouldn't work. You are right, though. Not all areas are protected, and you can indeed push files to your phone without root. /system/* is not one of those areas.

Hope that helps.
#7 novox77, Aug 8, 2010
Thanks Novox77, I'm guessing there is no way I can push my modified .apk than since it goes to the system/app :(
#8 Raadius, Aug 8, 2010
You can root your phone :) To even attempt what you are trying to do seems to indicate you're the type of person that would enjoy the benefits of rooting.

I'd give it some thought. And there's lots of ppl here to help you through it. If you do your research and understand what's going on, it's pretty hard to screw up your phone trying to root it.
#9 novox77, Aug 9, 2010

Any idea what I'm doing wrong?

I'm use a MacBook Pro. I was trying to push a boot animation with adb after 5 hours just gave up.

I DL'd SDK Android for Mac, put the boot animation zip in the tools folder, put the phone into recovery (bootloader usb) and connected it to my Mac, opened up Terminal and tried the following coomands:

./adb remount
./adb push /system/customize/resource
./adb reboot

This is what Terminal said:


I just can't get adb to work. No idea what I'm doing wrong.
#10 JG-1, Aug 9, 2010
based on your screenie, my guess is that your current directory is not the /tools directory of the SDK. Therefore, when you call ./adb, your computer is saying, "I don't see the command adb in this current directory."

A few unix basics:
~ = home directory
. = current directory
.. = parent directory
pwd = command to show you what directory you are in
cd ~ = go to your home dir. In your case, it appears to be johngirgenti/
cd .. = go back one directory (the parent)
cd / = go to the root directory (the parent of all folders; the root)
ls -al = list contents of the current directory in vertical list format and showing all hidden files (files beginning with a dot).

With these commands, you should be able to navigate the directories on your mac from the terminal.

when you say ./adb, you are saying current directory/adb. Based on your prompt, you seem to be in your home directory. Unless you have defined the location of adb in your PATH environment variable, you can't just run adb from any location. I don't know where the default location of the android SDK is for the Mac, but you should navigate there (tools directory) and try your ./adb command from there.

You are trying to replace the stupid 4G animation with your own 1337 animation. Here's how I'd do it, once you've verified you can get adb running:

Do this while your phone is in custom recovery.
#11 novox77, Aug 9, 2010
I thought I had it this time. Rebooted the phone and the animation wasn't there...I think I give

#12 JG-1, Aug 10, 2010
wrong directory. push it to /system/customize/resource/
**also note, you need to specify the target file**

be sure to mount /system first.

and there's also an mp3 file you can replace in /system/customize/resource. it's the one that plays with the boot animation. sounds like crap.
#13 novox77, Aug 11, 2010
Gotcha...what do you mean by mount /system first?

Sorry...slowly learning this adb stuff :(.

Yeah...have an mp3 file too....just push it the same way right?
#14 JG-1, Aug 11, 2010
Any idea?

#15 JG-1, Aug 11, 2010
Again....thought I had it this time



#16 JG-1, Aug 11, 2010
Tried to do the mp3...thought I had it but on reboot it didn't play, any idea's?


Tried this too...didn't work

#17 JG-1, Aug 11, 2010
Did it play the original sound at all? If not, then I'm guessing the issue is with your mp3 file. try something standard like 44khz@128.

Looks like your locations are different than mine. for me, on 2.1, the boot animation was in /system/customize/resource, and the sound was in /system/media. In 2.2 (for me), the sound was moved to /system/customize/resource, and it was also renamed.
#18 novox77, Aug 11, 2010
No, didn't play any sound.

Here's the mp3 file I'm trying to obviusly works on Evo's....just not sure why I can't get it to work.

[Boot Screen] Custom EVO animation - xda-developers
#19 JG-1, Aug 11, 2010
Pay close attention until you get the hang of it - ./adb means "execute adb from here" - .adb means nothing.
#20 EarlyMon, Aug 11, 2010
Yeah...I've been typing ./adb for hours...couple times I forgot the / in

Finally got it to work. Changed the file name to android_audio.mp3 and it finally flashed correctly.
#21 JG-1, Aug 11, 2010
sounds like you are still on 2.1? that file name and location rings a bell for my old 2.1 boot mp3.
#22 novox77, Aug 11, 2010
No, def on 2.2
#23 JG-1, Aug 11, 2010