Samsung Galaxy S5 Forum

General MMS over wifi only...

...on Verizon S5, and SMS mssg just fine. MMS, well not so fine. Only seems to work over Mobile Data.

I searched and found this thread:
I didn't read it as 'resolved' and was not sure if I should dredge it up...

I don't have unlimited data either, but the part that really hurts is, I have a Xoom tablet on VZ network and MMS comes across just fine w/mobile data turned off. Took both S5 & Xoom into store and showed VZW guy and it stumped him also. He sent a pic from his phone to my cell number and it came across tablet fine, but S5 just shows a generic block with the word "DOWNLOAD" in it. If you hit it, it says "DOWNLOADING..." but never does anything else.

Anyone conquer this stumbling block??? I really don't think a reset is going to fix this but will do it if consenus suggests it...



#1 sldghmrusa, May 24, 2014
I remember that thread and mentioned a friend on AT&T with an S3. He and I send photos back and forth via SMS w/o any problems.

From my understanding of how that works, attaching a photo to a standard SMS text msg invokes the MMS protocol. See => Multimedia Messaging Service - Wikipedia, the free encyclopedia

I disabled Message+ and installed Go SMS Pro which IMO does a much better job. I send pictures back and forth to my daughter's Windows phone all the time. sometimes on WiFi and other times via DATA w/WiFi not connected.

You need to download the Samsung Instruction Manual, it is 275 pages long and explains everything about the phone. Even how to use Scroll but that is not on a Verizon phone.

Get the Full 270 page GS5 - PDF manual from Samsung - Android Forums

Before you activate the phone, it would be a good idea to disable all of the Verizon bloatware that came with the phone. Especially Amazon Suites which eats up battery power for breakfast.

Settings/Application Manager/Applications/ALL
Scroll through that list and get rid of all the junk bloatware you don't want.
VZW Navigator is one because Verizon charges to use that service which is dumb when Google maps is free.

I completely configured my S5 on WiFi only before I activated it on Verizon. It was kind of neat playing with the phone w/o worrying about data charges.

If battery drain gets to be a problem for you, there are several threads on handling that issue also. Battery Doctor is my favorite to control that issue.

Let us know how you progress.
#2 AZgl1500, May 24, 2014
I have only WiFi enabled on my Verizon S5....

I just now sent myself a full size photo using Go SMS Pro.
I have my own phone number set up as a contact "Me"

The text body just had the words "Test Pictures", I touched the '+' sign and Go SMS Pro opened up a menu with a gob of different things to attach. Photos was the one I chose and selected a picture. It then asked me if I wanted to send MMS (< 0.3 MB) or BigMMS. I chose BigMMS.

It then popped up a small screen that states:
Big MMS Tips.
large files sent by Big MMS only cost one text message. (If receivers have not installed GO SMS PRO, they will get a link of BigMMS file) With GO SMS Pro your friends could view Big MMS files directly.

So there, you do NOT have to use DATA to send/receive photos or any other attachment via MMS.

YMMV, but we are both Verizon and it "just has to work" for you too.

#3 AZgl1500, May 24, 2014
Proper MMS will always go over the cellular network, there is no way of stopping this, its a feature thats built into the messaging protocols.

MMS is an extension of SMS. It dates back to when phones were pretty basic, and cameras on phones were just starting, people wanted a way of sending the pics to other phones.

The only way of sending 'MMS' through wifi is via one of the many messaging apps that the recipient has to have installed to view. (whatsapp etc).
#4 Tomo1971, May 25, 2014

See this for a full length description.

I really like GO SMS Pro, it will provide the recipient a URL to click on to see the files/photos, etc if they are not using a compatible message app.


Multimedia Messaging Service - Wikipedia, the free encyclopedia
#5 AZgl1500, May 25, 2014
I have not tried this with my S5 but I did have this problem of sending MMS over wifi with my old Nexus. I think I read an article saying that you needed to change something in the router to allow this to work.

Keep searching.
#6 bobo5884, May 27, 2014