Samsung Galaxy Note 4 Forum

Root Note 4 Root Help (Verizon, Marshmallow 6.0.1)

Hello, I am trying to root my Verizon note 4 but am running into trouble. I have followed multiple tutorials each basically saying the same thing and to no avail. I have the Samsung USB drivers installed, i have the most recent instance of SuperSU and im using TWRP- as included below. The problem i keep running into is a failure when trying to use odin. Here is what i get in the log.

<ID:0/004> Added!!
<ID:0/004> Odin engine v(ID:3.1005)..
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> SingleDownload.
<ID:0/004> recovery.img
<ID:0/004> NAND Write Start!!
<ID:0/004> RQT_CLOSE !!
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
<ID:0/004> Removed!!

I have a brand new data transfer cable just in case that was my problem.
I accessed developer mode and have USB Debugging on. I also have reactivation lock off.
Any help would be greatly appreciated. Thanks.


#1 eben48, Jul 30, 2016
Have you unlocked the bootloader yet?
I don't have a Note 4 but have read a few threads since they have found a exploit to unlock the bootloader.
#2 Jfalls63, Jul 30, 2016
From what ive read in other areas i have to have root access to unlock the boot loader.I would only need temp root access so i tried king root and its failed every time.I followed the steps in the link and it went through its process , booted up and started trying to automatically update. It doesn't look like that made much of a change.
#3 eben48, Jul 31, 2016
This is the first thread I found on the subject at XDA after checking a link to a different site.
One of the things I noticed was that your device CID had to start with 15

Seems that they found a way around it here.

I have been begging a co worker who has a Verizon Note 4 to let me have it for the weekend but sofar a nogo.
#4 Jfalls63, Jul 31, 2016
If you are in the phoenix area you can play with mine lol. Im still running into issues where i need temp root to get root. In the forum where i would change my version to lollipop i have to modify the cid with adb before i can flash the different version but i cant use the adb to take advantage of the unlocker tool because i don't have root. If im misinterpreting this please let me know but this is what i have tried so far.
#5 eben48, Jul 31, 2016
In Alabama. Other than what they have in the Note 4 Root section here
I think looking through the threads at XDA and using their search in the thread may be your best bet at a working solution.
Sorry I couldn't be more helpful. I even looked on Swappa for their cheapest used Note 4 to try it out but not worth $190 just to see if it works.
#6 Jfalls63, Jul 31, 2016
Looking over instructions here
They are flashing lollipop firmware with marshmallow bootloader that is rootable.
Rooting then installing the unlock package with ADB. Then flashing TWRP and a custom ROM.
#7 Jfalls63, Jul 31, 2016
After lots of trying i was able to successfully flash lollipop, unlock the bootloader using adb and adb minimal. For some reason adb minimal wouldn't push the file to my phone only adb would but after that adb didn't like to do any of the shell commands so i had to use minimal. its worked but i still haven't figured out why i had to add the extra step.and put su on my phone only to find out that i need a different kernel otherwise i get into a boot loop. So i did the whole process over again just to get a corrupted zip for my new kernel and get the boot loop again. Today now that i know what i'm doing i should be able to get it right lol. I'm just going to find a new kernel that is compatible and i should be good to go. I really appreciate the help.
#8 eben48, Aug 1, 2016 Last edited: Aug 1, 2016
I've been learning adb and Fastboot as I go. Did a few fastboot devices and pulled info with adb but haven't tried to push anything.
Stuff pretty interesting though.
Good luck.
#9 Jfalls63, Aug 1, 2016
Have read a few good things about this rom, might be the way to go.
#10 Jfalls63, Aug 1, 2016
It finally worked, your help has been invaluable thank you. I made that so much harder than it should have been
#11 eben48, Aug 1, 2016
Glad you got it the way you want it. Hope the links were useful. Maybe one day I'll get a Note 4 to play with. Itching to try it.
#12 Jfalls63, Aug 1, 2016
Don't use USB 3
#13 winlinand, Feb 25, 2017