Samsung Galaxy S5 Forum

Support S5 to PC Connection Problem

I have a new S5 from Verizon. I am not able to connect it to any of my PCs using a USB cable. The problem each time I try: MTP driver failed to load.

This happens on my four Win7 PCs and my one Win8 PC. Strangely, when I connect my S5 to a very old WinXP machine it connects with no problem. When I connect it to a friend


#1 pmokover, Jul 11, 2014
Sounds like you might need to redo the drivers for Samsung phones... a quick search led me to this link
#2 smith058, Jul 11, 2014
Hi, sorry to hear of your troubles, have you tried downloading and installing this USB driver? Phil
Support - Verizon Wireless Cell Phones SM-G900V | Samsung Cell Phones
#3 philayl, Jul 11, 2014
It could also be a bad cable. Do you know someone else with an S5 who would let you try their cable?

If re-installing the drivers still won't work, you can get similar cables on Amazon. I got a 3 pack of them for a reasonable price (I have wall chargers and car chargers distributed in various rooms and vehicles, so I can charge anywhere).

When I connect my S5 to a Win7 PC, it first shows being connected as "an installer". If I want to connect using MTP I have to tell the phone to do that. It closes the "installer" connection, then re-opens a connection as MTP. Are you seeing the same thing? If not, it might actually be something wrong in the phone.
#4 Zoandroid, Jul 14, 2014
Here are your options....

1. That old phone you have laying around? It just became useful again. Configure a Bluetooth connection between the old phone and your S5. Put an appropriate microSD card in the old phone and transfer media files from the S5 to the old phone as you wish and then copy them from the old phone to the PC over USB.

2. Get a cheap USB Bluetooth adapter and configure a connection between the S5 and your computer(s) to share files. Easy as can be!

3. Get a USB2microUSB thumb drive. It has micro USB on one end and regular USB on the other. Best Buy has a sale on the Sandisk models right now.
#5 DroidFromVA, Jul 14, 2014
Thanks for the reply. I have the latest drivers from the Samsung website. Unfortunately that didn't solve the problem.
#6 pmokover, Jul 14, 2014
Thanks for the reply.

1. I've tried multiple cables. Same results with all.

2. When I connect the S5 to a PC it is recognized as an installer - like you said. Then the MTP driver starts to load. As soon as that fails the PC no longer sees the phone.

#7 pmokover, Jul 14, 2014
I wonder if you can get a fresh copy of an MTP driver for Windows?

I was going to suggest a factory reset on the phone, but if your friend's S4 has the same issue (on your PCs) and you are able to connect to a friend's Win7 notebook, it almost sounds like the problem is with your PCs. Odd that all the ones newer than XP would share the issue. But........I do keep a couple rigs on XP just for this kind of thing. Some things just are a pain to do on Win7. Too many permissions involved.

Hmm. That has me thinking. Are you trying on your PCs as an administrator account login, or a user account? If you've not tried as an administrator account login, you might try that. Trying to think what might be different between you and your friend's Win7 installations, and that came to mind.
#8 Zoandroid, Jul 14, 2014

Interesting workarounds. However you might not be aware that the S5 uses a micro-USB3 jack. Don't know if any flash drives or Bluetooth dongles are available yet with that connector.

The S5 has bluetooth, so it might be able to transfer files that way, and of course there is always WiFi. But I am sure fixing the problem with the cable connection would be the desired goal.
#9 Zoandroid, Jul 14, 2014
Peter, I just tried Googling "Windows7 MTP driver". I suggest you do so. It seems you are not alone here. Not by a LONG shot. Maybe somewhere in all those hits you can find a solution. :)
#10 Zoandroid, Jul 14, 2014

I assure you that Micro USB 2.0 works just fine with the S5, so there's no problem with those flash drives. I've used all of the solutions that I presented because using a USB cable just doesn't work well due to the software issues that come with MTP. A Bluetooth connection is by far the easiest and quickest way to transfer files but so few computers have Bluetooth adapters. It's definitely the cheapest solution as you can get a Bluetooth adapter for $20.
#11 DroidFromVA, Jul 14, 2014
Thanks the reply, Zoandroid.

I copied the MTP driver files from my friend's Win7 laptop (where my S5 does connect) to one of my Win7 PCs. No change in the result. This makes me think that the problem is NOT my driver files but rather something is preventing those files from loading. I have no idea what that might be.

Speaking of drivers, I noted that when my S5 is connected to my friend's PC, in Device Manager the only S5 related driver that's loaded is "Samsung USB Composite Driver." The MTP driver which attempts/fails to load on my PCs does not even attempt to load on her PC. Why would that driver be necessary (but fail) on my PCs but not on hers?

I am logged on with an administrator account on all of my PCs.


#12 pmokover, Jul 14, 2014
This one was an interesting read:

Windows Mobile Device Cannot Connect (or Quickly Disconnect or Drop) and Not Sync with Vista WMDC (ActiveSync) « Tip and Trick

And is typical of some of the obscure ridculous-ness the Windows OS can bring upon a user. Problems with completely counter-intuitive solutions.

I think I'd look into the one referring to the registy edit if I were in your position, and then perhaps into this issue pointing at Media Player as the culprit. What kind of Anti-Virus software are you using, or have you ever used, on your Windows 7 PCs?
#13 Zoandroid, Jul 14, 2014
Ah. I got it now. Plug the S5 in. Finger the notification bar at the top and drag it down to reveal some hidden notifications, click on the USB connectivity notification to bring up an option switch the protocol to PTP, and off you gooooooooooooooo! Unfortunately, it looks like KitKat locks down the SD card slot and requires you to go through the phone/software to access it.
#14 DroidFromVA, Jul 14, 2014
I've spent the past two weeks living on Google over this problem. Hours every day. As you said, I am not alone with this problem. I have tried every suggestion I have found. No luck so far.

#15 pmokover, Jul 14, 2014
I have done the registry edits. I have also tried with AntiVirus disabled. Same result every time.
#16 pmokover, Jul 14, 2014
Thanks for the suggestion but switching to PTP didn't work. Switching back to MTP didn't do the trick either.
#17 pmokover, Jul 14, 2014

From what I just dug up, the latest Android shipping on new phones apparently has restrictions on SD card access, so you cannot connect the phone via USB and access the SD card storage directly. You'll have to use an app on the phone, Bluetooth file transfer, or sync to one of the micro-USB/USB flash drives using an appropriate app. Those are your choices.
#18 DroidFromVA, Jul 14, 2014
#19 pmokover, Jul 14, 2014
Well, I can't imagine why they did that but I would say it has some security uses. I get the gist that Google (and other companies) want to promote wireless connectivity as much as possible, hence the many WiFi/Bluetooth network storage devices that have cropped up over the past year like Sandisk's Wireless USB drive that can sync files with any current Android phone.
#20 DroidFromVA, Jul 14, 2014
So you've tackled this from the standpoint of it being something wrong with Windows? I am well aware of how software such as AV programs in Windows can have a trickle down effect into other things, making looking at Windows itself not seem like the path to take.

Next question. How long has it been since you did a completely clean reformat and installation of Windows on your PCs? "Windows rots". Sometimes tough problems can only be solved by starting over from scratch. It's easier to change a lightbulb than to do microscopic analysis on all the atoms of the filament to see which one lost cohesion, and why. ;)

But before you explore that route, here is one more simple step to try. Make a new administrator account on one of the Win7 PCs. Log off any open accounts and log into the new account. You may need to install the Samsung USB driver from the new account. Then try connecting the S5. I've seen too many problems brough about by "corrupt" user profiles in Windows. If that works, you'll need to use a new Windows user account to solve the problem.
#21 Zoandroid, Jul 14, 2014
That's not true, at last for me. My S5 transfers files from Phone and Card by USB 2.0 to my PC without any problems. However, my S5 is rooted. If yours is not, then indeed you can't write to the SD card "from any apps residing in internal memory". But you can still write to the SD card over USB from your PC. That's how I put Safestrap on the SD card to access it from the S5. Once rooted, there is a quick fix to remove the limitation on internal apps writing to the SD card.
#22 Zoandroid, Jul 14, 2014
I can tell you exactly why they did that.

The same reason they are making phones with no USB port, and no SD card. They want to take back the draconian control they had over cell phones prior to the emergence of the smartphone, with USB, and SD. Remember the first flip-phones? The only software on them was what you PAID FOR from your cell provider. We're headed back there, with these new sealed up phones that have no user removable battery, no USB, and no SD slot.
#23 Zoandroid, Jul 14, 2014
"Antivirus disabled" is not the same as scouring the registry and removing the "filter" listing they mentioned. Even un-installing the AV can leave that registry entry behind. Which AV programs have you ever used? If Norton or McAffee, then you apparently have that registry entry, even if you have removed them, if I read over that web page correctly. That's one Windows hassle - programs never clean up after themselves.
#24 Zoandroid, Jul 14, 2014
Those who believe that the SD card is locked down when connected to a PC and files can not be transferred, you are mistaken. The only time it is locked down is in terms of apps writing to it whilst the device is in use.

When I connect my device (NOT rooted) to the PC, it does not show up as a removeable device (like a USB drive would) and does not get assigned a drive letter. Instead it shows up under 'Portable Devices' "Galaxy S5 Portable Media Player" and when I open it I see two drives, one called Card and one called Phone. I can drag and drop files willy-nilly without an issue.

This may part of the problem that the OP is having - he is stating that it assigns it a drive letter and then fails and then it is not longer in windows explorer. Maybe it SHOULD be showing as a portable device as mine is (I made no tweaks, it always did it this way for me).

My device is set to MTP.
#25 Firey05, Jul 14, 2014