HTC EVO 4G Forum

Support Solutions - HTC Sense launcher error (process has stopped unexpectedly

"The application HTC Sense (process has stopped unexpectedly." - Error I was getting.

Background/Issue - I had LauncherPro set up(luckily) so had a launcher to fall back on, which I am/was using as default and installed/uninstalled several apps but had no issues... I decided to try HTC Sense again and was getting this error only when I launched HTC Sense... Restarting the phone or anything else didn't help. When I used LauncherPro everything was fine but when I tried HTC Sense got the error. Not sure if it was HTC Sense malfunctioning because of any conflicts with certain apps. I read a few posts and everybody had tried different apps before getting HTC Sense launcher error.

Solution 1 - The only solution I could find in posts was a factory reset which meant starting with a clean slate and customizing the whole thing and backing up stuff on the phone, data, etc... So I was reluctant to do that.

Since I was using LauncherPro I could use/access my phone flawlessly using LauncherPro, so if you have only HTC Sense and getting this error then I am not sure what you can do, maybe some other folks can share their experience. But this is how I solved it.

Solution 2 - Went to Settings > Applications > Manage Applications > HTC Sense > Clear Data. When I pressed Clear Data it gave me a message "All of this application's data will be deleted permanently. This includes all files, settings, accounts, databases and so on."I was hoping it wouldn't clean my entire phone like factory reset but when I clicked "OK" all I saw was it reset the HTC Sense's 7 screens(which I can deal with). All the data, SMS, Phone numbers, Accounts, Apps, etc. everything is intact... Phew!

Hope this helps somebody out there! If you have a different experience/solution please feel free to share it. All comments are welcome!

Started my first thread so please be gentle and hope it's in the right category, if not then mod could you please move it. Thanks and love this forum...


#1 way2success, Jul 13, 2010
i have the same problem on my evo 4g. except, i dont have launcher pro. here's the issue, i boot up my phone, and then when i slide down to unlock, there goes the error. force close. then it shows the white screen with green "htc" lettering, then rinse and repeat. over and over. it started happening right after i restored the phone to factory settings. what i've pulled so far by reading posts/forums/websites all over the net is that maybe its b/c my htc sense is trying to access a previous background that i had before the reset, which makes sense. the problem is that i CANT access my settings to navigate to the htc sense app to clear its data. so im pretty much screwed in that area. now when i try to clear it using ADB, it SEEMS as though can't be found. maybe im doing something wrong in ADB. i tried to

adb pull /data/data/

so that i could backup my layout and then restore it, see if that helps, but it says that path doesn't exist. i've also tried to reboot into recovery and wipe dalvik/format data, but it doesnt seem to recognise the format command. now i know some will ask, "well if you can get into your recovery, why not just format from there?" here's the next problem.. there's something wrong to the point that my power/lock button WILL NOT work while the phone is on. i can turn the phone on, but i cant turn it off. i can boot into recovery, but i cant select any options. oh, and my 'volume down/power' recovery freezes - it will read the sd, but afterwards, i cant even use the volume buttons to select a choice. im getting very frustrated. so please please PLEASE someone tell me they've found a solution. HTC EVO 4g, Sprint.
my brother suggests using his nand backup, but arent specific to the phone it was created on?
#2 TigerG8, May 21, 2011
ok well the issue you have is your power button. both recoveries use the power button to select from the given menu. so......not sure how you can fix this. what recovery do you have? if you have clockwork mod then maybe try using rom manager and download and flash sprint lovers rom then i would take it in to get fixed. i know that it is a risk, but hopefully you will have a working power button or a new(refurbished) evo. most sprint techs anyways do not really care if you are rooted.
#3 ocnbrze, May 22, 2011
update: so i managed to stop the force close thing, im back on my homescreen, i can now download/install apps! and for the people that HAPPEN to have the same issue i did, minus the power button (which still doesnt work when the phone is booted btw), in order to fix it.. assuming familiarity with adb..

-supposedly you can remove rosie.apk. i did; i wouldnt recommend it. but i installed (not pushed) launcherpro.apk, after removing rosie.apk. after reading some more, what i think would have fixed the problem from the beginning, is removing HtcAddProgramWidget.apk.

im wondering now, if the power button function is software related when the phone is on.. i'll try a remapper.

ocnbrze, im on clockwork. i thought about taking it in, except for the fact that i found my evo on a cab about 2 months ago. its fun for its capabilities. not needed for a phone, ya know? so there's nothing sprint would be able to do for me. so far i've just ordered all my pieces needed to refurbish it myself.. but nothing seems wrong w/ the power button, at all. which is why i think it may be software related. it happened after the wipe/factory reset.. and it still turns the phone on, allows me to boot into recovery, everything, except for locking the phone or turning it off. its like there's a block of some sort. im just gonna have to experiment some more :)
oh, does anyone have access to that super optimized rosie.apk? everytime i come across one, the link is broken =/
#4 TigerG8, May 25, 2011

This is happening to me right now and I'm about to lose my mind. I can't access my home screen. In fact, I can't access anything.

Any suggestions??
#5 bs872, Feb 23, 2013
I've been trying a hard reset for the last 20 minutes but the only thing that happens is the phone keep vibrating when I hold down the volume button and the power button.

#6 bs872, Feb 23, 2013
Pull the battery and leave it out for like 3 minutes.
Then put battery back in.
Then while holding the volume down button, push and hold the power button.
While continuing to hold both buttons, wait for a screen to come up.
That should be your bootloader screen.
Let us know if that screen comes up:)
#7 Mikestony, Feb 23, 2013
I did that and I'm back up and running with all of my contacts, pictures, etc..

Honestly, I've been contemplating a hard reset for a while and I guess I just needed some incentive.

Thanks for the input!
#8 bs872, Feb 23, 2013
Phew! Glad you got it going:D
#9 Mikestony, Feb 23, 2013
You and me both!

That continuous loop of force closings was NOT fun.

WTF is that, anyway??
#10 bs872, Feb 23, 2013
What were you doing before that started?
#11 Mikestony, Feb 23, 2013
I downloaded some update. After that, it was all over.
#12 bs872, Feb 23, 2013
Ah, the newest update that I just read about yesterday.
I follow ya. Yeah, who knows why that would happen. Perhaps a glitch in the system.
Did the update take?
I would surmise if it took, then you should be just fine:)
#13 Mikestony, Feb 23, 2013
I'm not sure.

Would a hard reset wipe that update out?
#14 bs872, Feb 23, 2013
In the future, before removing any "HTC" apps, try and use Titanium Backup to "freeze" them first. Freezing apps takes them off your screen and disables them but does NOT delete completely. That way, you can still "defrost" the app and return it. Good luck and have fun. Flashing a custom ROM is something that is highly recommended as they already have all the "bloat" (unnecessary Sprint or HTC apps) removed safely.:D
#15 tube517, Feb 24, 2013
no a hard reset just wipes data. it does not wipe the os or any updates. and also make sure that you have fastboot unchecked if you plan on going into the bootloader(power+vol down). to do that go to settngs>power>uncheck fastboot.
#16 ocnbrze, Feb 24, 2013
Okay, So of course with my luck none of the above is working for me.
I have no problem wiping the phone because I have backups but I cant get the phone to Wipe. When I go to the Recovery it attempts but then gives me a picture of the phone with a warning triangle, phone freezes and I have to reboot to access anything. Im not sure how the rest of you were able to access your settings because mine is kjust stuck in the loop, when I attempt to use the search feature it takes my request, attempts to process and then it too stops unexpectedly and force closes. At a real loss here. This occurred after the recent update.
#17 CMFD123191, Mar 2, 2013
welcome to the forums!!!!!!!!!!

are you rooted? what is your hboot and and radio, if you are?
#18 ocnbrze, Mar 2, 2013